
Lab 1:  Improving performance by LAN Hardware Upgrade 
 
Objective 
In this lab, OPNET’s IT Guru Academic Edition advanced modeling software will 
be used to study performance improvements in LAN obtained by upgrading 
switch hardware. We will also look at a wireless LAN topology and characterize it 
by looking at Media Access Delay values. 
 
You will learn the benefits of upgrading switch hardware in a congested LAN 
environment.  
 
Lab Project 
Friendly Care Hospital is one of the biggest hospitals in DC. It owns a 5-story 
building, and houses many departments that span multiple floors. Its Radiology 
department is spread across the first and second floor connected by a dedicated 
LAN. The department has recently deployed a new “Radiology Images” 
application as part of their initiative to digitize patient records. However, the 
department staff sometimes faces long application delays during busy hours. 
You, as their network engineer, are tasked with the job find the cause and 
recommend a solution. Also, Friendly Care is looking to design a wireless 
hospital for the future and wishes to study a proposed network design, using a 
completely different topology and traffic profile. 
 
Overview 
In this lab, there are 3 scenarios. The first two scenarios study the “Radiology 
Images” application performance on a 100 Mbps switched Ethernet network, and 
a 1 Gbps switched Ethernet network after a switch hardware upgrade. The third 
scenario focuses on evaluating a Wireless LAN, including low-level Media 
Access Delay (MAC) statistics, and high-level performance statistics like 
application response times. 
 
Lab Instructions 
Note: Bold marked words indicate menu/clickable options. 
 
Part 1: Understand the model and modeling environment 
 
1. Start IT Guru Academic Edition 9.1 (free download available at 
http://opnet.com/services/university/itguru_academic_edition.html) 
 
2. Select File -> Open… 
 
3. Scroll to the project named LAN_Lab_1, select it and click OK. If you do not 
see this project in the list, it means you have not downloaded and installed the 
labs properly.  For complete instructions, follow the steps on this page: 
http://opnet.com/services/university/Install_Lab.html. 
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4. The first scenario is named “100Mbps”. You can verify the project and 
scenario by observing the title bar (see screenshot below). 
 
 
 

 
 
 
In this scenario, groups of users belonging to Radiology Department are 
connected on a dedicated LAN containing two switches, one on each floor. A 

switched is indicated by the icon:  . The switches are named 

1st_Floor_Switch and 2nd_Floor_Switch. Groups of users  hit a variety of 
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servers  running file, database, HTTP, and Email services. The Radiology 
Images application is hosted on a server called Radiology_Imaging_Server.  This 
lab simulates users running these various applications between their 
workstations and the servers.  
 
Note: OPNET allows for abstracting background application demands into traffic flows, 
which are defined by specifying a source, a destination and a bits/sec rate between 
them. This feature helps in faster simulation without sacrificing accuracy, as we can use 
analytical techniques to calculate the statistics instead of performing intensive per-
packet based calculation. Thus various background demands that user places on the 
network have been encompassed into IP Flows here. We have hidden these demands 
for clarity purposes. For the curiously inclined, you may view these flows by clicking 
View -> Demand Objects -> Show All. To hide them, click View -> Demand Objects -
> Hide All. 
 
For input in this study, the groups of users are configured to run Email, HTTP, 
FTP and Radiology Image applications. 
 
For output, OPNET software provides many types of output performance 
statistics; low level statistics such as link bit error rate, switch queuing delays, 
and switch throughput, and high-level statistics like end-user application 
response times. We will focus on application response time and switch queuing 
delays on the links. 
 

5. Read the “Read Me” file by double-clicking the  icon. Then, click the  
icon in the toolbar to return to the topology in the project workspace, 
 
Continue navigating to explore and understand OPNET’s GUI and environment. 
OPNET’s models are made up of objects, which have attributes. An object’s 
attributes may be examined and changed by right-clicking it and selecting Edit 
Attributes. Any + sign indicates a compound attribute and may be expanded by 
clicking the + sign. “(…)” indicates a table underneath this attribute and double 
clicking it will show the table. 
 
Explore the attributes values of the following objects: Application Config 

, Profile Config , Tasks , and Workstation .  These 
attributes define the traffic that will get generated for the network (they are 
numerous and detailed and are beyond the scope of this lab). 
 
OPNET’s objects may be moved by drag-n-drop action, and can also be 
operated on by cut/copy/paste. The attribute values configure an object’s 
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behavior and act as input to the simulation engine.  Click Cancel whenever you 
wish to get out of any dialog box without changing the attribute values. 
 
For purposes of this lab, the attribute values have been tuned to ensure correct 
results and conclusions. Any change in these values may alter the results 
significantly. 
 
Understanding the network infrastructure: Here you will understand your network 
infrastructure, namely switches and links. 
 
6. Right click on one of the switches labeled 1st_Floor_Switch or 
2nd_Floor_Switch, and click Edit Attributes. 
 
7. Expand Switch Port Configuration, and then, expand row 0 (or any row) to 
see other details. Note the cost is set to Link Speed Based. Click on the help 
icon  across that row to learn what this costs basis means. 
 
8. In OPNET modeling environment, the data rate a switch can support is 
specified by the link data rate which connects to the switch.  Right click on the 
links between 1st_Floor_Switch and 2nd_Floor_Switch. Click Edit Attributes and 
note the data rate of the link. The units are in bits/sec. All links in this scenario 
are configured to be 100 Mbps. 
 
By now, you should have a feel of how to navigate the project workspace, and 
have an understanding of this scenario. You are now set to run the simulation.  
 
 
Part 2: Configure and Run the Simulation 
The goal is to evaluate the network performance for a simulated 1 hour of the 
busy part of the day by running a high-fidelity Discrete Event Simulation. 

1. Click on the configure/run simulation toolbar button. . 
 
2. Make sure the Simulation Duration is set to 1 hour. 
 
3. Click Run. Monitor the progress bar as the simulation proceeds. 
 
4. When the simulation completes, Click Close. 
 
 
Part 3: View Results 
Application Response Times for Email, FTP, HTTP and Radiology Images 
applications as observed by end-user and link utilization statistics will be 
reviewed in this section. It is important to note their values because in the next 
scenario we will improve this performance by upgrading switch hardware. 
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1. Click on Results->View Results.  
 
View Application Response Times: 
 
2. Expand Global Statistics, Email and FTP. 
 
3. Select Download Response Time (sec) and Upload Response Time (sec) 
for both Email and FTP. The selected graphs will be plotted on the right-side of 
the frame. On the lower-right side, make sure the settings are Stacked 
Statistics, This Scenario and As Is. Click Show. A window is created with the 
graphs containing the raw data for the Email and FTP application response 
times. 
 
4. Click the As Is drop-down menu and select average. This will convert the raw 
data into an average curve. Click Add and then click on the top-most graph of 
the window that you created in step 3. Now you have both the raw data and 
average graphs for Email and FTP application response times.  
 
Note: If you did not follow the underlined instructions above, you may have mismatched 
raw data and average graphs, so close the graph, choose Delete and go through steps 
3 and 4 again. 
 
You may place the resulting window anywhere on your desktop by dragging it by 
its header bar. 
 
5. Go back to the ‘View Results’ window and unselect the previously selected 
choices for Email and FTP.  
 
6. Repeat steps 2-4 for HTTP and Custom Application. Select Page Response 
Time (seconds) for HTTP and Application Response Time (sec) for Custom 
Application. Close the View Results window when done. 
 
View Top 10 Link Utilization and Queuing Delay Values: 
 
7. Click Results -> Find Top Results. Expand Link Statistics -> point-to-point 
and select utilization and click Find Top Results button. You will see link 
utilization values in a table sorted in descending order based on Average 
column. 
 
8. Click on the Maximum column name and sort by decreasing order. You 
should observe two links with 100% maximum utilization.  
 
9. Click on Graphs Stacked drop-down menu and select Graphs Overlaid. Click 
Graph.  Close the Top Objects window.  
 
10. Repeat steps 7-9 for queuing delays instead of utilization. Click Close on 
the Select Statistic for Top Results window. 
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What do you observe? 
 
Answer: Link utilization reaches 100% at times causing application response 
times to peak. 
 
You should now have 4 graphs as shown below. 
 

 
 
Note: To toggle the graphs on and off, use the hide or show all graphs 
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button.  
 
11. Hide the graphs so that you now see the topology. 
 
12. To visualize link statistics in yet another way, click on Results -> Visualize 
Link Statistics… In the left box, increase the Red number from 75 to 85. Click 
Show. You will see the links colored based on the utilization threshold set earlier. 
Red color indicates link which has peak utilization values greater than 85%. The 
utilization values are directional indicated by split colors on links. Verify the two 
links with 100% maximum utilization in red are the same you saw in the graph. 
You can view peak link utilization values in the tool tip when you move your 
mouse on top of the colored link. 
 
 
Part 4: Switch scenarios to simulate the same network with 1 Gbps links 
 
1. Click on Scenarios ->Switch Scenarios.  
 
2. Choose 1 Gbps scenario. 
 

3. Read the README file by clicking the  icon. It is important to understand 
how switch hardware upgrades are modeled in OPNET software. 
 
4. To examine the change in attributes of the links, right-click on the two links 
which had reached 100% peak utilization in the previous scenario, and click Edit 
Attributes. Note the data rate of these links has increased to 1 Gbps. 
 
5. Repeat all the steps in Part 2: Configure and Run the Simulation 
 
6. You may choose to repeat all steps in Part 3: View Results to view the results 
separately for this scenario OR you may choose to compare results between this 
and the previous scenario for selected metrics. 
 
7. To compare results, click Results -> Compare Results. Expand Global 
Statistics and any application of your choice. Click on the various application 
response time metrics we saw in Part 3: View Results (e.g Download 
Response Time for Email, Upload Response Time for FTP, and Application 
Response Time for Custom Application etc). You will be able to select only one 
metric at a time since you are comparing. Make sure you have the options 
Overlaid Statistics, All Scenarios, and As Is set in their respective drop-down 
menus. Click Show. Repeat this step for as many metrics as you want.  
 
What do you observe? 
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Answer: The spikes in the application response time metrics have disappeared.  
The reason is the switch hardware upgrade (modeled by a link data rate increase 
in OPNET software) which now supports 1 Gbps line data rate is now capable of 
handling the traffic load thereby removing any bottlenecks in the network. Users 
(doctors) would now be able to access the applications and experience no 
slowness in response times. 
 
8. Repeat steps 7-12 in Part 3: View Results to verify that the link utilization and 
queuing delay values have dropped significantly in this scenario due to hardware 
upgrade. 
 
Note: Components of Network Delays are Bandwidth Delay, Protocol Delay, Delay due 
to Latency, and Congestion Delay. Delay due Bandwidth and Latency are typically not 
found in LAN. Queuing delay falls within Congestion Delay category. 
 
 
Part 5: Assessing Wireless LANs  
 
Friendly Care Hospital is contemplating moving towards wireless offices in future 
months. With growth, they expect to relocate to 4 buildings, each connected to 
the outside by a wired router. Within each building, the workstations will be 
wireless, connected to a wireless access point. This is their first (preliminary) 
wireless design, and they want to evaluate it using OPNET software. Hence, they 
have decided to keep the topology and traffic straightforward with workstations 
running only Web-based applications. 
 
In this lab exercise, we will focus on examining Media Access Delay values, an 
important component of characterizing Wireless LANs.  
 
1. Switch Scenarios to WLAN Scenario. Refer Step 1 in Part 4: Switch 
Scenarios to switch. 
 
2. To understand this new topology, double click on any of the office building 

subnet icon . 
 
3. Each building is configured with workstations connected wirelessly to an 
access point (an Ethernet router) supporting a 1 Mbps data link. Explore attribute 

values of various devices. Click the  icon in the toolbar to return up a level in 
the subnet hierarchy. 
 
4. Configure and Run the Discrete Event Simulation as outlined Part 2: 
Configure and Run the Simulation. Ensure the simulation run time is set to 8 
hours. 
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5. Click on Results->View Results.  
 
6. Expand Global Statistics -> HTTP. Click Page Response Time and Show. 
Note the time it takes for an end-user to load an HTTP page. 
 
HTTP Page Response Time: 
Min ____________     Max ____________ Avg ____________ 
 
7. Deselect all options. 
 
8. Expand Wireless LAN. Click Media Access Delay (sec) and Show. Note the 
value.  
Note: Should you choose to do the extra credit assignment, you will need this value for 
comparison purposes. 
 
MAC Delay for Wireless LAN Scenario: 
Min ____________     Max ____________ Avg ____________ 
 
MAC Delay for Access Point (bldg1): 
Min ____________     Max ____________ Avg ____________ 
 
9. Add the average option to view both the raw data and running average 
curves.  Refer to Step 4 of Part 3: View Results for instructions. 
 
Optional: Graph the statistics for the various Access Points and wired Routers.  
Hint: Expand Object Statistics->Campus Network in the View Results window. 
 
Extra Credit: Here we just saw two workstations per Wireless LAN. How would 
the values of Media Access Delay and HTTP Page Response Time change if 
there were 10 workstations per Wireless LAN … or 30? Duplicate the scenario 
(Scenarios / Duplicate Scenario) and create new ones to study the increased 
number of workstations.  Use copy-paste functionality in OPNET software to 
increase the number of workstations in one of the buildings and run Discrete 
Event Simulation by going through the steps in Part 5: Assessing Wireless 
LANs section. 
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